Register
Results 1 to 5 of 5
  1. #1

    How to "clean up" TSM and hopefully reduce memory usage?

    Hey guys, over the last few months I've imported and exported tons of different strings and even though I delete them, it seems they're all still saved in TradeSkillMaster.lua inside SavedVariables and it's using a lot of memory.

    I use the desktop app to updated Auction DB. Here are my versions (http://imgur.com/tFVUnRR) and a screenshot of memory usage (http://imgur.com/a/bUegt).

    How do I go about clearing all the extra fluff while keeping my "settings". I'm not too worried about groups or operations, but I have tinkered with a few options. If there's no other way of doing this without losing everything, I'm fine with that.

    Thanks!

  2. #2
    Gumdrops's Avatar
    Posts
    702
    Reputation
    33
    Tagged in
    178 Posts
    Add to this user's reputation
    That's a relatively normal amount, there's not really much you can do to improve that.

  3. #3
    Quote Originally Posted by Gumdrops View Post
    That's a relatively normal amount, there's not really much you can do to improve that.
    OK, and wouldn't reducing the file size of TSM.lua help with loading? Maybe? I just see a ton of old stuff in there, even though I don't have any of those groups setup.

    Thanks!

  4. #4
    How many are you talking about? My ADB is 117MB, TSM is 46, Acc 12, Craft 5, destroy 4 so 184MB. IDK but I guess deleting a few dozen groups might save a quite small % of that?

  5. #5
    Sapu94's Avatar
    Posts
    7,105
    Reputation
    343
    Blog Entries
    25
    Tagged in
    1928 Posts
    Add to this user's reputation
    Deleting groups is unlikely to have any impact on loading times.


    Follow me and TSM on Twitter for important updates, news, and giveaways!
    TSM Website | TSM Chat Channel (IRC) | Donate | TSM FAQ

    "A good programmer is someone who always looks both ways before crossing a one-way street."

 

 

Similar Threads

  1. Replies: 6
    Last Post: February 16th, 2016, 04:38 AM
  2. Replies: 10
    Last Post: October 9th, 2014, 09:01 AM
  3. "restart" and "start post scan" macro?
    By Farah in forum General TradeSkillMaster Discussion
    Replies: 1
    Last Post: December 7th, 2013, 08:00 AM
  4. Bug Question: "Per Auction" and "Post Cap" not functioning correctly
    By kyledgebhart in forum General TradeSkillMaster Discussion
    Replies: 1
    Last Post: December 26th, 2011, 09:10 PM
  5. Suggestion: "Save Setting" button near new "show sales" checkbox.
    By fluxdada in forum Official Forum of The Undermine Journal
    Replies: 1
    Last Post: June 13th, 2011, 02:49 PM

Tags for this Thread