Register
Welcome to the Stormspire.net WoW Gold Forums!

Greetings, guest! Welcome to Stormspire.net, your #1 resource for WoW and Diablo 3 Gold, Professions, and everything in between!


Enjoy what the site offers? Consider Premium Membership if you wish to get the most out of the site. Premium Membership benefits include the acclaimed Goblineer's World of Warcraft Gold Guide, private forum access, a complimentary high-quality avatar, and much more!


If this is your first visit, make sure to check out the Stormspire.net Survival Guide for a quick site orientation. You may also register to unlock all standard forum features, and to get rid of these lovely ads!


We proudly host the Official forums for TradeSkillMaster, The Undermine Journal, and WoWuction.

Results 1 to 9 of 9
  1. #1
    Apprentice
    WoWDsvid's Avatar
    Posts
    2
    Reputation
    0
    Tagged in
    0 Posts
    Add to this user's reputation

    TSM App Continuous restarting

    Greetings,
    The TSM App notified me it had updated itself and needed to re-start. I selected on and it restarted, only to notify me again it had updated and needed to restart. It is in an infinite restart loop. Any Fix?

  2. #2
    US-Zul'Jin(A)
    Ethereal Contributor
    Gorddygecko's Avatar
    Posts
    20
    Reputation
    0
    Tagged in
    5 Posts
    Add to this user's reputation

  3. #3
    Apprentice
    WoWDsvid's Avatar
    Posts
    2
    Reputation
    0
    Tagged in
    0 Posts
    Add to this user's reputation
    Thanks, removing the tsmapplication_old.exe did it.

  4. #4
    Entrepreneur
    croana's Avatar
    Posts
    11
    Reputation
    0
    Tagged in
    0 Posts
    Add to this user's reputation
    I had to remove both the TSMApplication_old.exe and TSMAppLog.txt to get it to work.

  5. #5
    Ethereal Contributor
    T-Fed's Avatar
    Posts
    4
    Reputation
    0
    Tagged in
    1 Posts
    Add to this user's reputation
    ok,on my mac running most recent os, i have done everything you suggest (excepting changing the name. it already has simply TSMApplication, and when oit does open, it is r440 and it just keeps giving me the recent update message and demanding restart

  6. #6
    Ethereal Contributor
    T-Fed's Avatar
    Posts
    4
    Reputation
    0
    Tagged in
    1 Posts
    Add to this user's reputation
    ok ignore that, i have it working but i don't have any idea what i have done correctly this time.

    i am just sooo glad to have it working

  7. #7
    Entrepreneur
    natassja's Avatar
    Posts
    29
    Reputation
    0
    Tagged in
    8 Posts
    Add to this user's reputation
    Oh wow, it took me 2 days to realize that the app hasnt been running at all after it wanted to restart after update! How many deals I lost - who knows! It never restarted and after manual start it keept wanting to restart. Now I will know next time there's update to the app to delete those files manually!

  8. #8
    EU-DarkSpear(A)
    TSM Developer
    Bart39's Avatar
    Posts
    1,136
    Reputation
    58
    Tagged in
    368 Posts
    Add to this user's reputation
    Quote Originally Posted by natassja View Post
    Oh wow, it took me 2 days to realize that the app hasnt been running at all after it wanted to restart after update! How many deals I lost - who knows! It never restarted and after manual start it keept wanting to restart. Now I will know next time there's update to the app to delete those files manually!
    this was hopefully fixed in r46 so further updates should be ok (you may have to repeat the same steps though from r45 > r46)
    Sic has joined #TradeSkillMaster
    I love you all. TSM Has given me children.
    That is all.
    Sic has left #TradeSkillMaster

    TSM Application Developer / Assistant Addon Developer

    For information: TSM Website, TSM Addon, TSM App.
    Also Follow TSM on Twitter, and Like TSM on Facebook!
    If you need help with any of the above hop on Chat. It's much faster than posting

  9. #9
    Apprentice
    oneCof5's Avatar
    Posts
    1
    Reputation
    0
    Tagged in
    0 Posts
    Add to this user's reputation
    Quote Originally Posted by T-Fed View Post
    ok,on my mac running most recent os, i have done everything you suggest (excepting changing the name. it already has simply TSMApplication, and when oit does open, it is r440 and it just keeps giving me the recent update message and demanding restart
    I encountered the exact same circumstance: the app (r44) would open, download, and prompt for restart... then loop. I followed the instructions (rename the TSMApplication.app/Contents/MacOS/TSMApplication_Old) but it would always revert back to r44.

    After several trials and errors, I finally moved TSMApplication back to the main Applications folder (I had been running it under Applications/"World of Warcraft"/TSM/TSMApplication.app). That switch on the path resolved the issue and it upgraded to r46.

    TLDR? If you're looping on a Mac, ensure you've got TSMApplication in your main Applications folder, not a custom location.

    FWIW

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •