Register
Results 1 to 10 of 10
  1. #1

    Scroll macro only works on main?

    Hello! I have recently started using TSM on my alts and noticed the scroll macro for posting is not working. Any idea why?

    Thanks

  2. #2
    Sapu94's Avatar
    Posts
    7,114
    Reputation
    346
    Blog Entries
    25
    Tagged in
    1928 Posts
    Add to this user's reputation
    Did you try deleting and remaking the macro? Make sure you're not hovering over anything else that might eat your scroll wheel clicks (like the log).


    Follow me and TSM on Twitter for important updates, news, and giveaways!
    TSM Website | /r/woweconomy & TSM Discord | Go Premium | TSM FAQ

    "A good programmer is someone who always looks both ways before crossing a one-way street."

  3. #3
    I had the same problem, make sure your macros arn't set to player specific. I'm at work atm, but I'm pretty sure there's a button on the macro page

  4. #4
    Its in the general macro section on all toons... I dont know whats going on and I am not hovering over anything. It works on my main and I am aware I have to hover to the right of the AH window. Hmmm.

  5. #5
    Sapu94's Avatar
    Posts
    7,114
    Reputation
    346
    Blog Entries
    25
    Tagged in
    1928 Posts
    Add to this user's reputation
    You might have something else bound to the modifier you used. Try a different modifier or a combination of 2 of them.


    Follow me and TSM on Twitter for important updates, news, and giveaways!
    TSM Website | /r/woweconomy & TSM Discord | Go Premium | TSM FAQ

    "A good programmer is someone who always looks both ways before crossing a one-way street."

  6. #6
    Aeriwen's Avatar
    Posts
    28
    Reputation
    16
    Tagged in
    11 Posts
    Add to this user's reputation
    I had to set and reset it a few times. The work around for me is to set the binding that you want to use via the keybindings (it doesn't matter what), and then clear it, and then go back to TSM and set it again. It usually starts working again after that.

  7. #7
    I have to tie the scroll wheel up and down to that macro on each toon that uses it. This might be possible across accounts, but I am not sure. The macro is shared, but the key binding seems to not be shared.

  8. #8
    harleqin's Avatar
    Posts
    33
    Reputation
    0
    Tagged in
    2 Posts
    Add to this user's reputation
    What usually works for me when it seems faulty (I'm not quite sure how I figured this out) is to simply do a /macro and choose a thumbnail for the TSM macro. And it suddenly works!

  9. #9
    THE FIX:
    I had the same issue, came to this thread, and then just experimented around. Got it first try: Go into your TSM where you make the macro, set a different modifier key, create the macro, then change the key back, and create again. Fixed it for me!

  10. #10
    Hi all! i know that this is an old post but I had the same problem 5 minutes ago. Just make sure that your mouse is over "Post" when you want to use the macro, otherwise the macro doesn't work. Hope this help to someone Cheers!

 

 

Similar Threads

  1. Scroll profit spreadsheet (With TUJ import)
    By Hacez in forum Archive (Tools, Programs and Spreadsheets)
    Replies: 9
    Last Post: September 24th, 2012, 12:15 PM
  2. How Warehousing Works and How to Set it Up
    By Reverb in forum General TradeSkillMaster Discussion
    Replies: 21
    Last Post: August 12th, 2012, 02:51 PM
  3. Finally works for EU!
    By savchris in forum Official Forum of The Undermine Journal
    Replies: 16
    Last Post: September 26th, 2011, 12:24 PM
  4. How to master the scroll market.
    By Teryx in forum Archive (Professions)
    Replies: 5
    Last Post: July 21st, 2011, 06:52 AM
  5. Scroll Master version for Inscription
    By Zenit in forum Archive (Addons and Macros)
    Replies: 6
    Last Post: January 16th, 2011, 06:03 AM